Microsoft Attack Surface Analyzer Error Message

Q: I have “Microsoft .NET Framework 4 Client Profile” installed, but when installing Microsoft Attack Surface Analyzer I get the message:

You are attempting to install Attack Surface Analyzer on a system without .Net 4 or above.  If you continue with the installation, only the command-line executable asa.exe and the data collection components of Attack Surface Analyzer will be installed.  To continue with installation, click Next.  If you do not want to continue with installation, click Cancel.

A: Do you also show “Microsoft .NET Framework 4 Extended” installed? If not, then install it before installing Microsoft Attack Surface Analyzer. Alternately, the command-line executable asa.exe is not such a bad idea.

Advertisements

Comments are closed.